AWS基盤障害によるサーバ停止の原因調査

質問

⚠️ この事例は公開されてから1年以上経過しています。 情報が古い可能性がありますので、ご注意ください。

🕓 事例公開日 : 2025-03-14

【背景】

本番環境システムで2月26日の夜間にサーバ停止が発生し、アプリケーション側の調査では原因が特定できなかったため、基盤側での問題発生の有無を確認したい。



1. 事象

発生したアラート:

2024-02-26 22:27:19  プロセス監視 123456789000 APサーバダウン検知2024-02-26 22:27:45  AWS基盤監視 am-storage-123456789000 ステータス異常検知2024-02-26 22:31:12  URL監視 123456789000 エラー検知2024-02-26 22:31:28  am-ap01-123456789000 ロードアベレージ (10分間12超過)2024-02-26 22:31:54  am-ap01-123456789000 ロードアベレージ (10分間6超過)2024-02-26 22:32:29  AWS基盤監視 am-storage-123456789000 ステータス異常検知

症状の説明:

22:27頃からサーバプロセスの停止、ストレージの異常、URL応答エラー、高負荷状態が連続して発生した。最終的に23:00頃にサーバ再起動を実施して復旧した。



2. 発生条件

・発生日時:2024年2月26日 22:27~23:21
・対象環境:本番環境システム
・復旧方法:サーバ再起動による復旧

回答

1. 原因

AWS基盤側の問題により、EC2インスタンスに障害が発生し、サービスが停止しました。

2. 対応結果

AWS側で対応完了しており、EC2インスタンスは現在正常に稼働しています。

3. 調査方法

1. サービス停止の確認(2024年2月26日22:27頃)
2. 対象システムの状態確認とストレージサーバの調査
3. AWSへの問い合わせ
4. 障害報告の取得と原因確認(AWS基盤側の問題と判明)
この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています
Powered by Zendesk