RDS CPU使用率スパイク上昇の原因調査

質問

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🕓 事例公開日 : 2025-04-15

【背景】

リソース監視システムから以下のアラートが届いたが、CPU使用率が急上昇した理由に心当たりがない状況。
RDS-database01-123456789012 CPU使用率 (10分間95%超過)



1. 事象

症状の説明:

RDSのCPU使用率が短時間で95%を超過し、リソース監視からアラートが発生した。



2. 質問内容

RDSのCPU使用率が上昇している原因として考えられるものを知りたい。
また、原因特定に使用できるログファイル名も教えてほしい。

回答

1. 原因

技術的な原因:

2025-03-18 14:14:58から14:16:58の間に発生したCPU使用率のスパイク現象で、継続的な高負荷ではなく一時的な処理集中が原因でした。

技術的要因の分析:

・ホーム画面(https://example.com/foo/bar)へのリクエスト処理 → データベースへの高負荷クエリ実行
・ポータル画面での複数ポートレット同時実行 → データベースリソースの競合状態
・ViewCreatorによるデータ参照処理 → 大量データアクセスによるCPU負荷
・独自実装処理でのSQL発行 → 非効率なクエリによるリソース消費

根本的な要因:

ホーム画面表示時に実行される処理の中で、データベースCPUに負荷をかける処理が含まれていることが主要因です。

2. 対応方法

根本解決方法:

1. ポータル画面のポートレットを個別に実行し、CPU使用率上昇の原因となる処理を特定する
2. ViewCreatorのデータ参照処理内容を確認し、負荷の高いクエリを最適化する
3. 独自実装処理でデータベースCPUに負荷をかけるSQLが発行されていないかチェックする

暫定対処方法:

該当時間帯のリクエストを再現テストし、負荷をかけている具体的な処理を特定してください。

3. 原因特定に使用できるログ

調査対象ログファイル:

・intra-martリクエストログ:リクエスト・レスポンスに関連する情報を記録

ログ解析ツール:

「im-log-stats」を使用したログ解析により、負荷の高い処理を効率的に特定できます。

参考ドキュメント:

・問題の切り分け、原因特定作業: https://aws.accel-mart.com/support_inquiry_guide/texts/inquiry_process/support_category_decision/failure_analysis.html#root-cause-analysis
・CPU使用率上昇の対応方法: https://cloud.intra-mart.support/hc/ja/articles/17161895455001
・リソース状態異常FAQ: https://cloud.intra-mart.support/hc/ja/sections/16801982682265

4. 今後の調査依頼について

弊社への原因調査依頼時は、事前の問題切り分けや原因特定に関する情報準備が必要です。詳細は以下をご確認ください。 ・障害調査ガイド: https://aws.accel-mart.com/support_inquiry_guide/texts/inquiry_process/support_category_decision/failure_analysis.html
・必要情報の準備: https://aws.accel-mart.com/support_inquiry_guide/texts/inquiry_process/support_category_decision/failure_analysis.html#prepare-failure-analysis-inquiry
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