定期バックアップ失敗の原因調査

質問

⚠️ この事例は公開されてから1年以上経過しています。 情報が古い可能性がありますので、ご注意ください。

🕓 事例公開日 : 2024-12-18

【背景】

定期バックアップが失敗する事象が発生し、原因を特定したい。



1. 事象

エラーメッセージ・スタックトレース:

開始日時:2024/12/01 00:30:35終了日時:2024/12/01 00:30:35コメント:週次定期バックアップ詳細:他機能が実行中のため、処理を終了しました。システムステータスが稼働中であることを確認し、再度実行してください。

症状の説明:

週次定期バックアップが異常終了している。該当時刻にユーザー操作は行われておらず、バッチ処理も実行されていない。システム管理者画面から各種ログファイルを確認したが、該当のエラーログを見つけることができない。



2. 発生条件

・発生日時:2024/12/01 00:30:35
・対象機能:Accel-Mart Plus の監視機能、定期処理
・ユーザー操作なし、バッチ処理なしの状況で発生

3. 質問内容

1. 該当時刻にAccel-Mart Plus側で実行された処理があるか知りたい
2. バックアップ失敗時の詳細な原因がログファイル等に出力されるか、その取得方法を教えてほしい

回答

1. 原因

技術的な原因:

週次定期バックアップと月次定期バックアップが同じ日時(2024/12/01 00:30)に実行されたため、月次バックアップのみが実施され、週次バックアップが処理を終了し異常終了となりました。

技術的要因の分析:

・スケジュール重複:週次バックアップと月次バックアップが同一時刻に設定 → 処理の競合が発生
・排他制御:バックアップ処理の排他制御により先行処理が優先 → 後続処理が異常終了
・処理優先度:月次バックアップが優先実行 → 週次バックアップが「他機能実行中」で終了

根本的な要因:

バックアップスケジュールの設定において、週次と月次の実行タイミングが重複していることが根本原因です。

2. 対応方法

根本解決方法:

1. 運用管理サイトにアクセス
2. バックアップの実行スケジュール設定画面を開く
3. 週次バックアップと月次バックアップの実行時刻を重複しないよう調整
4. 設定変更を保存し、次回実行予定を確認

暫定対処方法:

失敗した週次バックアップについては、システムステータスが稼働中であることを確認後、手動で再実行してください。

3. バックアップログの詳細について

バックアップ結果のログは運用管理サイトに出力されており、個社利用環境では参照できません。
この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています
Powered by Zendesk