モジュール追加後に標準テーマカスタマイズでimmファイルがダウンロードできない

質問

🕓 事例公開日 : 2026-04-07

【背景】

モジュールを追加した後、標準テーマカスタマイズ機能を使おうとしている。



1. 事象

症状の説明:

サイトマップから「標準テーマカスタマイズ」→「標準テーマ作成」の画面にアクセスしたが、immファイルのダウンロードができない状態になっている。



2. 発生条件

モジュール追加後、warファイルのみを反映し、静的ファイルの配置を行っていない環境で発生。

回答

1. 原因

技術的な原因:

モジュール反映時に静的ファイルが配置されていなかったため、標準テーマカスタマイズ機能が正常に動作しませんでした。

技術的要因の分析:

  • 要因1:warファイルのみを反映し、静的ファイルの配置を実施していなかった → 画面表示に必要なリソースが不足
  • 要因2:静的ファイル未配置の状態で標準テーマカスタマイズ画面にアクセス → 機能が正常に動作せず、immファイルのダウンロードが実行できない

根本的な要因:

モジュール反映時に、warファイルと静的ファイルの両方を配置する必要があるが、静的ファイルの配置が漏れていたことが根本原因です。

2. 対応方法

根本解決方法:

  1. IM-Jugglingプロジェクトから静的ファイルを作成する
  2. 作成した静的ファイルをモジュール反映機能で配置する
  3. ブラウザのキャッシュをクリアする
  4. 標準テーマカスタマイズ画面にアクセスし、immファイルのダウンロードが可能になったことを確認する

補足事項:

モジュール追加時には、テナント環境セットアップの実施も必要です。ただし、既にセットアップ済みの場合は、テナント環境セットアップボタンが表示されないため、再実施は不要です。

テナント環境セットアップについては、以下のドキュメントをご参照ください。

intra-mart Accel Platform システム管理者操作ガイド - テナント環境セットアップ
https://document.intra-mart.jp/library/iap/public/operation/system_administrator_guide/texts/basic_guide/basic_guide_2.html

3. 原因究明に至るまでの調査方法

  1. 対象環境のモジュール反映履歴を確認し、静的ファイルの配置が実施されていないことを特定
  2. モジュール反映時には、warファイルと静的ファイルの両方が必要であることを確認
  3. 静的ファイル未配置が原因で標準テーマカスタマイズ機能が動作していないと判断
  4. 静的ファイルの配置を依頼し、事象が解消されることを確認
この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています
Powered by Zendesk