🚨 緊急対処 🚨
原因調査よりもまず復旧を優先したい場合は、以下の関連FAQを確認してください。
・個社利用環境にアクセスできない場合の緊急対処方法を教えてください。
https://cloud.intra-mart.support/hc/ja/articles/62702967448857
📌 前提
この記事は、個社利用環境にアクセスできなくなった場合に、発生している症状に応じた原因調査の進め方を案内しています。
詳細な調査手順は、各調査フロー内のリンク先記事を確認してください。
個社利用環境にアクセスできない状態は、リソース(CPU・メモリ・ディスク)の逼迫や、アプリケーション側のログに記録されるエラー、アプリケーションライセンスの期限切れなど、様々な要因で発生する可能性があります。
この記事では、発生している症状によって調査フローをリソース・基盤系、ライセンス・権限系に分岐し、それぞれの調査フローを案内します。
- リソース・基盤系 :個社利用環境にアクセスできない、原因の見当がつかない場合の調査フロー
- ライセンス・権限系:特定の機能のみ利用できない、権限エラーが表示される場合の調査フロー
どちらに該当するか判断がつかない場合は、まず「1. リソース・基盤系の調査フロー」から確認することを推奨します。
1. リソース・基盤系の調査フロー
このフローでは、サーバのリソース状況からログ調査へと段階的に絞り込み、個社利用環境にアクセスできなくなった原因を特定します。
まずサーバのリソース(CPU・メモリ・ディスク)の状況を確認し、リソースに異常が見られない場合は、アプリケーション側のログ(Resin JVMログ)、続いて通信側のログ(リクエストログ)へと段階的に確認を進めます。
【該当症状】
個社利用環境にアクセスできない、サーバが落ちている、再起動を試したが直らない など
※現在準備中の項目です。今後、内容を順次公開予定です。
なお、ステップ1〜3を確認した結果、いずれにも異常が見られない場合は、 その他の調査フロー、および、 その他に考えられる原因もご確認ください。
2. ライセンス・権限系の調査フロー
このフローでは、特定の機能やアプリケーションのみ利用できない場合に、ライセンスの有効期限切れが原因かどうかを確認します。
こちらは原因が一つに特定できるケースが多いため、「1. リソース・基盤系の調査フロー」ステップを踏まずに直接確認してください。
【該当症状】
環境自体は起動している、システム管理者画面での接続は可能である など
※現在準備中の項目です。今後、内容を順次公開予定です。
なお、ステップ4を確認した結果、いずれにも異常が見られない場合は、 その他の調査フロー、および、 その他に考えられる原因もご確認ください。
📌 補足事項
本記事を確認しても問題が解決しない場合は、Accel-Mart Plus サービスサポート窓口に問い合わせてください。
詳しくは以下を参照してください。
■ Accel-Mart Plus お問い合わせガイド - お問い合わせのプロセス
https://aws.accel-mart.com/support_inquiry_guide/texts/inquiry_process/index.html
なお、障害調査に関する問い合わせの場合、問題の切り分けや、問い合わせに必要な情報の準備が必要です。
詳細については以下のドキュメントを参照してください。
■ Accel-Mart Plus お問い合わせガイド - 障害調査
https://aws.accel-mart.com/support_inquiry_guide/texts/inquiry_process/support_category_decision/failure_analysis.html
■ Accel-Mart Plus お問い合わせガイド - 問い合わせに必要な情報の準備
https://aws.accel-mart.com/support_inquiry_guide/texts/inquiry_process/support_category_decision/failure_analysis.html#prepare-failure-analysis-inquiry
また弊社では、これまでご契約者様から寄せられたお問い合わせ内容のうち、他のご契約者様の参考になりうる事例を「お問い合わせ事例集」として公開しております。
本記事で取り上げている個社利用環境へのアクセス不可事象についても、類似の事例が事例集に掲載されている場合があります。
本記事の調査フローと合わせてご確認のうえ、より早期に原因の特定・解決につなげてください。
■ お問い合わせ事例集
https://cloud.intra-mart.support/hc/ja/categories/50390328493721
【その他に考えられる原因】
メンテナンス中、運用管理機能の実行中、接続元IPアドレスの未許可等が原因となっている場合があります。
以下の関連FAQを確認してください。
・個社利用環境にアクセスを試みましたが、ログイン画面が表示されませんでした。原因について教えてください。
https://cloud.intra-mart.support/hc/ja/articles/16551720245273