個社利用環境にアクセスできない場合の緊急対処方法を教えてください。

【前提】

この記事は、個社利用環境が以下のような状況であり、原因調査よりもまず復旧を優先したい場合の対処方法について記載しています。

  • 個社利用環境にアクセスができない
  • 画面が真っ白、または、「ただいまサービスをご利用いただけません」等のエラーが表示される
  • 特定のエラーコードは出ておらず、原因の見当がつかない

 

【回答】

1. サーバ再起動

まずAPサーバやDBサーバの再起動を試してください。
アクセス不可の原因によっては、再起動により状況が改善される可能性があります。

弊社のサーバ起動・停止の操作は、APサーバとDBサーバで分かれています。
APサーバの再起動を実施ではDBサーバは再起動されないため、DBサーバ側の負荷が原因の場合は、別途DBサーバの再起動を実施してください。



どちらのサーバを再起動すべきか判断がつかない場合は、以下を参考にしてください。
まず、事象発生の直前に何らかの操作を実施していないか確認してください。

  • 設計書出力や集計処理等、高負荷処理を実行していた場合 → APサーバ再起動
  • 大量データのインポート・登録作業を実施していた場合     → DBサーバ再起動

心当たりがない場合や、判断がつかない場合は、運用管理サイトの「リソース表示」で以下を確認してください。

  • APサーバのCPU使用率・メモリ使用率が高い状態が続いている → APサーバ再起動
  • DBサーバ(RDS)のCPU使用率が高い状態が続いている   → DBサーバ再起動

 

「リソース表示」の操作方法については、以下のドキュメントを参照してください。

■Accel-Mart Plus 運用者操作ガイド - リソース表示
https://aws.accel-mart.com/am_document/texts/system_operation/resource_display/index.html

※どちらのサーバを再起動すべきか判断がつかない場合や、AP・DBサーバ両方を再起動されたい場合は、DBサーバの再起動を実施してください。DBサーバの再起動により、APサーバもあわせて再起動されます。

 

【サーバ再起動の所要時間】

  • APサーバ再起動 ※所要時間の目安:15分前後(再起動するサーバ台数により変動します)
  • DBサーバ再起動 ※所要時間の目安:10分前後

詳細の手順については、以下のドキュメントを参照してください。

■Accel-Mart Plus 運用者操作ガイド - サーバを再起動する
https://aws.accel-mart.com/am_document/texts/system_operation/system_information.html#server-restart

■Accel-Mart Plus 運用者操作ガイド - DBサーバを再起動する
https://aws.accel-mart.com/am_document/texts/system_operation/system_information.html#db

 

2. リストア

再起動を実施しても復旧しない場合、原因の切り分けよりも早期の復旧を優先するため、既存に取得しているバックアップを利用したリストアを検討してください。
所要時間の目安は40分前後です。(バックアップのデータ量により変動します)

リストアを実施する際は、事象が発生し始めた時点よりも前に取得されたバックアップを利用してください。
事象発生後に取得されたバックアップでは、同じ要因を含んだ状態に戻ってしまい、リストア後も同様の事象が再発する可能性があります。

なお、バックアップの取得タイミング(日次・週次等)によっては、事象発生前のバックアップが存在しない場合や、直近のバックアップから事象発生までの期間が長く、データが大きく古くなる場合があります。
その場合、バックアップ取得時点以降に登録・更新された運用データは復元されませんので、バックアップの取得時点を確認のうえ、運用への支障を踏まえてリストアを検討してください。

また、弊社メンテナンス作業実施日以前の時点へのリストアはできませんので、あらかじめ留意してください。
リストアの実施方法については、以下のドキュメントを参照してください。

■Accel-Mart Plus 運用者操作ガイド - リストア
https://aws.accel-mart.com/am_document/texts/system_operation/restore.html

 

⚠️注意:リストアを実施すると、リストアに使用したバックアップの取得時点以降に登録された業務データやログが失われます(例:9/6 15:00時点のバックアップでリストアを実施した場合、9/6 15:00以降からリストア実施直前までのデータが失われます)。
これにより原因調査が困難になるだけでなく、失われたデータの復旧もできなくなりますので注意してください。

原因調査の実施や業務データの消失回避を検討される場合は、リストア実施前に可能な限りログ・業務データの退避をお願いします。

 

【補足】

緊急対処により復旧した場合も、根本原因は特定できていない状態です。
原因調査を行う場合は、以下の関連FAQを確認してください。

・個社利用環境にアクセスできない場合の原因調査方法を教えてください。
https://cloud.intra-mart.support/hc/ja/articles/61341121064473 

サーバ再起動・リストアを実施しても復旧しない場合は、Accel-Mart Plus サービスサポート窓口へ問い合わせてください。
詳しくは以下を参照してください。

■ Accel-Mart Plus お問い合わせガイド - お問い合わせのプロセス
https://aws.accel-mart.com/support_inquiry_guide/texts/inquiry_process/index.html


なお、障害調査に関する問い合わせの場合、問題の切り分けや、問い合わせに必要な情報の準備が必要です。
詳細については以下のドキュメントを参照してください。

■ Accel-Mart Plus お問い合わせガイド - 障害調査
https://aws.accel-mart.com/support_inquiry_guide/texts/inquiry_process/support_category_decision/failure_analysis.html

■ Accel-Mart Plus お問い合わせガイド - 問い合わせに必要な情報の準備
https://aws.accel-mart.com/support_inquiry_guide/texts/inquiry_process/support_category_decision/failure_analysis.html#prepare-failure-analysis-inquiry

 

この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています
Powered by Zendesk